Gentoo Logo

Apache mod_python Denial of Service vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200401-03 / mod_python
Release Date January 27, 2004
Latest Revision December 30, 2007: 02
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apache/mod_python < 2.7.10 >= 2.7.10 All supported architectures

Related bugreports: #39154


Apache's mod_python module could crash the httpd process if a specific, malformed query string was sent.

2.  Impact Information


Mod_python is an Apache module that embeds the Python interpreter within the server allowing Python-based web-applications to be created.


The Apache Foundation has reported that mod_python may be prone to Denial of Service attacks when handling a malformed query. Mod_python 2.7.9 was released to fix the vulnerability, however, because the vulnerability has not been fully fixed, version 2.7.10 has been released.

Users of mod_python 3.0.4 are not affected by this vulnerability.


Although there are no known public exploits known for this exploit, users are recommended to upgrade mod_python to ensure the security of their infrastructure.

3.  Resolution Information


Mod_python 2.7.10 has been released to solve this issue; there is no immediate workaround.


All users using mod_python 2.7.9 or below are recommended to update their mod_python installation:

Code Listing 3.1: Resolution

$> emerge sync
$> emerge -pv ">=www-apache/mod_python-2.7.10"
$> emerge ">=www-apache/mod_python-2.7.10"
$> /etc/init.d/apache restart

4.  References


Page updated January 27, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.