Gentoo Logo

Multiple remote buffer overflow vulnerabilities in Courier


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200403-06 / Courier
Release Date March 26, 2004
Latest Revision March 26, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-mail/courier-imap < 3.0.0 >= 3.0.0 All supported architectures
mail-mta/courier < 0.45 >= 0.45 All supported architectures

Related bugreports: #45584


Remote buffer overflow vulnerabilities have been found in Courier-IMAP and Courier MTA. These exploits may allow the execution of abritrary code, allowing unauthorized access to a vulnerable system.

2.  Impact Information


Courier MTA is a multiprotocol mail server suite that provides webmail, mailing lists, IMAP, and POP3 services. Courier-IMAP is a standalone server that gives IMAP access to local mailboxes.


The vulnerabilities have been found in the 'SHIFT_JIS' converter in 'shiftjis.c' and 'ISO2022JP' converter in 'so2022jp.c'. An attacker may supply Unicode characters that exceed BMP (Basic Multilingual Plane) range, causing an overflow.


An attacker without privileges may exploit this vulnerability remotely, allowing arbitrary code to be executed in order to gain unauthorized access.

3.  Resolution Information


While a workaround is not currently known for this issue, all users are advised to upgrade to the latest version of the affected packages.


All users should upgrade to current versions of the affected packages:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=net-mail/courier-imap-3.0.0"
# emerge ">=net-mail/courier-imap-3.0.0"
# ** Or; depending on your installation... **
# emerge -pv ">=mail-mta/courier-0.45"
# emerge ">=mail-mta/courier-0.45"

4.  References


Page updated March 26, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.