Gentoo Logo

ipsec-tools contains an X.509 certificates vulnerability.

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200404-05 / ipsec-tools
Release Date April 07, 2004
Latest Revision April 07, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-firewall/ipsec-tools <= 0.2.4 >= 0.2.5 AMD64

Related bugreports: #47013

Synopsis

ipsec-tools contains a vulnerability that affects connections authenticated with X.509 certificates.

2.  Impact Information

Background

From http://ipsec-tools.sourceforge.net/ :

"IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec implementation."

Description

racoon (a utility in the ipsec-tools package) does not verify digital signatures on Phase1 packets. This means that anybody holding the correct X.509 certificate would be able to establish a connection, even if they did not have the corresponding private key.

Impact

Since digital signatures are not verified by the racoon tool, an attacker may be able to connect to the VPN gateway and/or execute a man-in-the-middle attack.

3.  Resolution Information

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

ipsec-tools users should upgrade to version 0.2.5 or later:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-firewall/ipsec-tools-0.2.5"
# emerge ">=net-firewall/ipsec-tools-0.2.5"


Print

Page updated April 07, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.