Gentoo Logo

Util-linux login may leak sensitive data

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200404-06 /
Release Date April 07, 2004
Latest Revision April 07, 2004: 01
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
sys-apps/util-linux <= 2.11 >= 2.12 All supported architectures

Related bugreports: #46422

Synopsis

The login program included in util-linux could leak sensitive information under certain conditions.

2.  Impact Information

Background

Util-linux is a suite of essential system utilites, including login, agetty, fdisk.

Description

In some situations the login program could leak sensitive data due to an incorrect usage of a reallocated pointer.

NOTE: Only users who have PAM support disabled on their systems (i.e. -PAM in their USE variable) will be affected by this vulnerability. By default, this USE flag is enabled on all architectures. Users with PAM support on their system receive login binaries as part of the pam-login package, which remains unaffected.

Impact

A remote attacker may obtain sensitive data.

3.  Resolution Information

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

All util-linux users should upgrade to version 2.12 or later:

Code Listing 3.1: Resolution

# emerge sync


# emerge ">=sys-apps/util-linux-2.12"

4.  References



Print

Page updated April 07, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.