Gentoo Logo

Multiple new security vulnerabilities in monit

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200404-16 / monit
Release Date April 19, 2004
Latest Revision April 19, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/monit <= 4.2 >= 4.2.1 All supported architectures

Related bugreports: #47631

Synopsis

Two new vulnerabilities have been found in the HTTP interface of monit, possibly leading to denial of service or execution of arbitrary code.

2.  Impact Information

Background

Monit is a system administration utility that allows management and monitoring of processes, files, directories and devices on a Unix system.

Description

Monit has several vulnerabilities in its HTTP interface : a buffer overflow vulnerability in the authentication handling code and a off-by-one error in the POST method handling code.

Impact

An attacker may exploit the off-by-one error to crash the Monit daemon and create a denial of service condition, or cause a buffer overflow that would allow arbitrary code to be executed with root privileges.

3.  Resolution Information

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

Monit users should upgrade to version 4.2.1 or later:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=app-admin/monit-4.2.1"
# emerge ">=app-admin/monit-4.2.1"

4.  References



Print

Page updated April 19, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.