Gentoo Logo

libpng denial of service vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200405-06 / libpng
Release Date May 14, 2004
Latest Revision May 14, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-libs/libpng <= 1.2.5-r4 >= 1.2.5-r5 All supported architectures

Related bugreports: #49887

Synopsis

A bug in the libpng library can be abused to crash programs making use of that library to decode PNG images.

2.  Impact Information

Background

libpng is a standard library used to process PNG (Portable Network Graphics) images.

Description

libpng provides two functions (png_chunk_error and png_chunk_warning) for default error and warning messages handling. These functions do not perform proper bounds checking on the provided message, which is limited to 64 bytes. Programs linked against this library may crash when handling a malicious PNG image.

Impact

This vulnerability could be used to crash various programs using the libpng library, potentially resulting in a denial of service attack on vulnerable daemon processes.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are advised to upgrade to the latest available version of libpng.

Resolution

All users of libpng should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=media-libs/libpng-1.2.5-r5"
# emerge ">=media-libs/libpng-1.2.5-r5"

You should also run revdep-rebuild to rebuild any packages that depend on older versions of libpng :

Code Listing 3.2: Resolution

# revdep-rebuild

4.  References



Print

Page updated May 14, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.