Gentoo Logo

Pound format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200405-08 / pound
Release Date May 18, 2004
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/pound <= 1.5 >= 1.6 All supported architectures

Related bugreports: #50421

Synopsis

There is a format string flaw in Pound, allowing remote execution of arbitrary code with the rights of the Pound process.

2.  Impact Information

Background

Pound is a reverse proxy, load balancer and HTTPS front-end. It allows to distribute the load on several web servers and offers a SSL wrapper for web servers that do not support SSL directly.

Description

A format string flaw in the processing of syslog messages was discovered and corrected in Pound.

Impact

This flaw may allow remote execution of arbitrary code with the rights of the Pound daemon process. By default, Gentoo uses the "nobody" user to run the Pound daemon.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are advised to upgrade to the latest available version of Pound.

Resolution

All users of Pound should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=www-servers/pound-1.6"
# emerge ">=www-servers/pound-1.6"

4.  References



Print

Page updated May 18, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.