Gentoo Logo

Icecast denial of service vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200405-10 / icecast
Release Date May 19, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/icecast <= 2.0.0 >= 2.0.1 All supported architectures

Related bugreports: #50935

Synopsis

Icecast is vulnerable to a denial of service attack allowing remote users to crash the application.

2.  Impact Information

Background

Icecast is a program that streams audio data to listeners over the Internet.

Description

There is an out-of-bounds read error in the web interface of Icecast when handling Basic Authorization requests. This vulnerability can theorically be exploited by sending a specially crafted Authorization header to the server.

Impact

By exploiting this vulnerability, it is possible to crash the Icecast server remotely, resulting in a denial of service attack.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are advised to upgrade to the latest available version of Icecast.

Resolution

All users of Icecast should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-misc/icecast-2.0.1"
# emerge ">=net-misc/icecast-2.0.1"

4.  References



Print

Page updated May 19, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.