Gentoo Logo

CVS heap overflow vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200405-12 / cvs
Release Date May 20, 2004
Latest Revision May 20, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-util/cvs <= 1.11.15 >= 1.11.16 All supported architectures

Related bugreports: #51460


CVS is subject to a heap overflow vulnerability allowing source repository compromise.

2.  Impact Information


CVS (Concurrent Versions System) is an open-source network-transparent version control system. It contains both a client utility and a server.


Stefan Esser discovered a heap overflow in the CVS server, which can be triggered by sending malicious "Entry" lines and manipulating the flags related to that Entry. This vulnerability was proven to be exploitable.


A remote attacker can execute arbitrary code on the CVS server, with the rights of the CVS server. By default, Gentoo uses the "cvs" user to run the CVS server. In particular, this flaw allows a complete compromise of CVS source repositories. If you're not running a server, then you are not vulnerable.

3.  Resolution Information


There is no known workaround at this time. All users are advised to upgrade to the latest available version of CVS.


All users running a CVS server should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=dev-util/cvs-1.11.16"
# emerge ">=dev-util/cvs-1.11.16"

4.  References


Page updated May 20, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.