Gentoo Logo

CVS: additional DoS and arbitrary code execution vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200406-06 / CVS
Release Date June 10, 2004
Latest Revision June 10, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-util/cvs <= 1.11.16-r1 >= 1.11.17 All supported architectures

Related bugreports: #53408


Several serious new vulnerabilities have been found in CVS, which may allow an attacker to remotely compromise a CVS server.

2.  Impact Information


CVS (Concurrent Versions System) is an open-source network-transparent version control system. It contains both a client utility and a server.


A team audit of the CVS source code performed by Stefan Esser and Sebastian Krahmer resulted in the discovery of several remotely exploitable vulnerabilities including:

  • no-null-termination of "Entry" lines
  • error_prog_name "double-free()"
  • Argument integer overflow
  • serve_notify() out of bounds writes


An attacker could use these vulnerabilities to cause a Denial of Service or execute arbitrary code with the permissions of the user running cvs.

3.  Resolution Information


There is no known workaround at this time. All users are advised to upgrade to the latest available version of CVS.


All CVS users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=dev-util/cvs-1.11.17"
# emerge ">=dev-util/cvs-1.11.17"

4.  References


Page updated June 10, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.