Gentoo Logo

Horde-IMP: Input validation vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200406-11 / horde-imp
Release Date June 16, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/horde-imp <= 3.2.3 >= 3.2.4 All supported architectures

Related bugreports: #53862


An input validation vulnerability has been discovered in Horde-IMP.

2.  Impact Information


Horde-IMP is the Internet Messaging Program. It is written in PHP and provides webmail access to IMAP and POP3 accounts.


Horde-IMP fails to properly sanitize email messages that contain malicious HTML or script code.


By enticing a user to read a specially crafted e-mail, an attacker can execute arbitrary scripts running in the context of the victim's browser. This could lead to a compromise of the user's webmail account, cookie theft, etc.

3.  Resolution Information


There is no known workaround at this time.


All Horde-IMP users should upgrade to the latest stable version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=www-apps/horde-imp-3.2.4"
# emerge ">=www-apps/horde-imp-3.2.4"

4.  References


Page updated June 16, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.