Gentoo Logo

Usermin: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200406-15 / Usermin
Release Date June 18, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-admin/usermin <= 1.070-r1 >= 1.080 All supported architectures

Related bugreports: #54030

Synopsis

Usermin contains two security vulnerabilities which could lead to a Denial of Service attack and information disclosure.

2.  Impact Information

Background

Usermin is a web-based administration tool for Unix. It supports a wide range of user applications including configuring mail forwarding, setting up SSH or reading mail.

Description

Usermin contains two security vulnerabilities. One fails to properly sanitize email messages that contain malicious HTML or script code and the other could allow an attacker to lock out a valid user by sending an invalid username and password.

Impact

By sending a specially crafted e-mail, an attacker can execute arbitrary scripts running in the context of the victim's browser. This can be lead to cookie theft and potentially to compromise of user accounts. Furthermore, an attacker could lock out legitimate users by sending invalid login information.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

Usermin users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=app-admin/usermin-1.080"
# emerge ">=app-admin/usermin-1.080"

4.  References



Print

Page updated June 18, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.