Gentoo Logo

Apache 1.3: Buffer overflow in mod_proxy


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200406-16 / Apache
Release Date June 21, 2004
Latest Revision December 30, 2007: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache <= 1.3.31-r1 >= 1.3.31-r2 All supported architectures

Related bugreports: #53544


A bug in mod_proxy may allow a remote attacker to execute arbitrary code when Apache is configured a certain way.

2.  Impact Information


The Apache HTTP Server Project is an effort to develop and maintain an open-source HTTP server for modern operating systems. The goal of this project is to provide a secure, efficient and extensible server that provides services in tune with the current HTTP standards.


A bug in the proxy_util.c file may lead to a remote buffer overflow. To trigger the vulnerability an attacker would have to get mod_proxy to connect to a malicous server which returns an invalid (negative) Content-Length.


An attacker could cause a Denial of Service as the Apache child handling the request, which will die and under some circumstances execute arbitrary code as the user running Apache, usually "apache".

3.  Resolution Information


There is no known workaround at this time. All users are encouraged to upgrade to the latest available version:


Apache 1.x users should upgrade to the latest version of Apache:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=www-servers/apache-1.3.31-r2"
# emerge ">=www-servers/apache-1.3.31-r2"

4.  References


Page updated June 21, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.