Gentoo Logo

mod_ssl: Format string vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200407-18 / mod_ssl
Release Date July 22, 2004
Latest Revision July 22, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-www/mod_ssl <= 2.8.18 >= 2.8.19 All supported architectures

Related bugreports: #57379


A bug in mod_ssl may allow a remote attacker to execute arbitrary code when Apache is configured to use mod_ssl and mod_proxy.

2.  Impact Information


mod_ssl provides Secure Sockets Layer encryption and authentication to Apache 1.3.


A bug in ssl_engine_ext.c makes mod_ssl vulnerable to a ssl_log() related format string vulnerability in the mod_proxy hook functions.


Given the right server configuration, an attacker could execute code as the user running Apache, usually "apache".

3.  Resolution Information


A server should not be vulnerable if it is not using both mod_ssl and mod_proxy. Otherwise there is no workaround other than to disable mod_ssl.


All mod_ssl users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=net-www/mod_ssl-2.8.19"
# emerge ">=net-www/mod_ssl-2.8.19"

4.  References


Page updated July 22, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.