Gentoo Logo

PuTTY: Pre-authentication arbitrary code execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-04 / PuTTY
Release Date August 05, 2004
Latest Revision May 22, 2006: 03
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/putty <= 0.54 >= 0.55 All supported architectures

Related bugreports: #59383

Synopsis

PuTTY contains a vulnerability allowing a SSH server to execute arbitrary code on the connecting client.

2.  Impact Information

Background

PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms, along with an xterm terminal emulator.

Description

PuTTY contains a vulnerability allowing a malicious server to execute arbitrary code on the connecting client before host key verification.

Impact

When connecting to a server using the SSH2 protocol an attacker is able to execute arbitrary code with the permissions of the user running PuTTY by sending specially crafted packets to the client during the authentication process but before host key verification.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of PuTTY.

Resolution

All PuTTY users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-misc/putty-0.55"
# emerge ">=net-misc/putty-0.55"

4.  References



Print

Page updated August 05, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.