Gentoo Logo

Cfengine: RSA Authentication Heap Corruption


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-08 / Cfengine
Release Date August 10, 2004
Latest Revision May 22, 2006: 05
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/cfengine <= 2.1.7 >= 2.1.8, < 2.0.0 All supported architectures

Related bugreports: #59895


Cfengine is vulnerable to a remote root exploit from clients in AllowConnectionsFrom.

2.  Impact Information


Cfengine is an agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks.


Two vulnerabilities have been found in cfservd. One is a buffer overflow in the AuthenticationDialogue function and the other is a failure to check the proper return value of the ReceiveTransaction function.


An attacker could use the buffer overflow to execute arbitrary code with the permissions of the user running cfservd, which is usually the root user. However, before such an attack could be mounted, the IP-based ACL would have to be bypassed. With the second vulnerability, an attacker could cause a denial of service attack.

3.  Resolution Information


There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Cfengine. (It should be noted that disabling cfservd will work around this particular problem. However, in many cases, doing so will cripple your Cfengine setup. Upgrading is strongly recommended.)


All Cfengine users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=net-misc/cfengine-2.1.8"
# emerge ">=net-misc/cfengine-2.1.8"

4.  References


Page updated August 10, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.