Gentoo Logo

gv: Exploitable Buffer Overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200408-10 / gv
Release Date August 12, 2004
Latest Revision August 12, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/gv <= 3.5.8-r3 >= 3.5.8-r4 All supported architectures

Related bugreports: #59385

Synopsis

gv contains an exploitable buffer overflow that allows an attacker to execute arbitrary code.

2.  Impact Information

Background

gv is a PostScript and PDF viewer for X which provides a user interface for the ghostscript interpreter.

Description

gv contains a buffer overflow vulnerability where an unsafe sscanf() call is used to interpret PDF and PostScript files.

Impact

By enticing a user to view a malformed PDF or PostScript file an attacker could execute arbitrary code with the permissions of the user running gv.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of gv.

Resolution

All gv users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=app-text/gv-3.5.8-r4"
# emerge ">=app-text/gv-3.5.8-r4"

4.  References



Print

Page updated August 12, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.