Gentoo Logo

eGroupWare: Multiple XSS vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200409-06 / eGroupWare
Release Date September 02, 2004
Latest Revision May 22, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/egroupware <= 1.0.00.003 >= 1.0.00.004 All supported architectures

Related bugreports: #61510

Synopsis

The eGroupWare software contains multiple cross site scripting vulnerabilities.

2.  Impact Information

Background

eGroupWare is a suite of web-based group applications including calendar, address book, messenger and email.

Description

Joxean Koret recently discovered multiple cross site scripting vulnerabilities in various modules for the eGroupWare suite. This includes the calendar, address book, messenger and ticket modules.

Impact

These vulnerabilities give an attacker the ability to inject and execute malicious script code, potentially compromising the victim's browser.

3.  Resolution Information

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of eGroupWare.

Resolution

All eGroupWare users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync

# emerge -pv ">=www-apps/egroupware-1.0.00.004"
# emerge ">=www-apps/egroupware-1.0.00.004"

4.  References



Print

Page updated September 02, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.