Gentoo Logo

mpg123: Buffer overflow vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200409-20 / mpg123
Release Date September 16, 2004
Latest Revision September 16, 2004: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-sound/mpg123 <= 0.59s-r3 >= 0.59s-r4 All supported architectures

Related bugreports: #63079

Synopsis

mpg123 decoding routines contain a buffer overflow bug that might lead to arbitrary code execution.

2.  Impact Information

Background

mpg123 is a MPEG Audio Player.

Description

mpg123 contains a buffer overflow in the code that handles layer2 decoding of media files.

Impact

An attacker can possibly exploit this bug with a specially-crafted mp3 or mp2 file to execute arbitrary code with the permissions of the user running mpg123.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mpg123 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=media-sound/mpg123-0.59s-r4"
# emerge ">=media-sound/mpg123-0.59s-r4"

4.  References



Print

Page updated September 16, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.