Gentoo Logo

Foomatic: Arbitrary command execution in foomatic-rip filter

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200409-24 / foomatic
Release Date September 20, 2004
Latest Revision September 20, 2004: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-print/foomatic <= 3.0.1 >= 3.0.2 All supported architectures
net-print/foomatic-filters <= 3.0.1 >= 3.0.2 All supported architectures

Related bugreports: #64166

Synopsis

The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server.

2.  Impact Information

Background

Foomatic is a system for connecting printer drivers with spooler systems such as CUPS and LPD. The foomatic-filters package contains wrapper scripts which are designed to be used with Foomatic.

Description

There is a vulnerability in the foomatic-filters package. This vulnerability is due to insufficient checking of command-line parameters and environment variables in the foomatic-rip filter.

Impact

This vulnerability may allow both local and remote attackers to execute arbitrary commands on the print server with the permissions of the spooler (oftentimes the "lp" user).

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All foomatic users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge sync
# emerge -pv ">=net-print/foomatic-3.0.2"
# emerge ">=net-print/foomatic-3.0.2"

PLEASE NOTE: You should update foomatic, instead of foomatic-filters. This will help to ensure that all other foomatic components remain functional.

4.  References



Print

Page updated September 20, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.