Gentoo Logo

Apache 2.0: Denial of Service by memory consumption

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-18 / apache
Release Date November 10, 2004
Latest Revision December 30, 2007: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-servers/apache < 2.0.52-r1 >= 2.0.52-r1, < 2.0 All supported architectures

Related bugreports: #70138

Synopsis

A flaw in Apache 2.0 could allow a remote attacker to cause a Denial of Service.

2.  Impact Information

Background

The Apache HTTP Server is one of the most popular web servers on the Internet.

Description

Chintan Trivedi discovered a vulnerability in Apache httpd 2.0 that is caused by improper enforcing of the field length limit in the header-parsing code.

Impact

By sending a large amount of specially-crafted HTTP GET requests a remote attacker could cause a Denial of Service of the targeted system.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Apache 2.0 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.52-r1"

4.  References



Print

Page updated November 10, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.