Gentoo Logo

Samba: Multiple vulnerabilities


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-21 / samba
Release Date November 11, 2004
Latest Revision November 15, 2004: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-fs/samba < 3.0.8 >= 3.0.8, < 3.0 All supported architectures

Related bugreports: #70429


Samba is vulnerable to a buffer overflow that could lead to execution of arbitrary code (CAN-2004-0882). Another flaw in Samba may allow a remote attacker to cause a Denial of Service by excessive consumption of CPU cycles (CAN-2004-0930).

2.  Impact Information


Samba is a freely available SMB/CIFS implementation which allows seamless interoperability of file and print services to other SMB/CIFS clients.


Samba fails to do proper bounds checking when handling TRANSACT2_QFILEPATHINFO replies. Additionally an input validation flaw exists in ms_fnmatch.c when matching filenames that contain wildcards.


An attacker may be able to execute arbitrary code with the permissions of the user running Samba. A remote attacker may also be able to cause an abnormal consumption of CPU resources, resulting in slower performance of the server or even a Denial of Service.

3.  Resolution Information


There is no known workaround at this time.


All Samba users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-fs/samba-3.0.8"

4.  References


Page updated November 11, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.