Gentoo Logo

Open DC Hub: Remote code execution

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-37 / opendchub
Release Date November 28, 2004
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-p2p/opendchub < 0.7.14-r2 >= 0.7.14-r2 All supported architectures

Related bugreports: #72371

Synopsis

Open DC Hub contains a buffer overflow that can be exploited to allow remote code execution.

2.  Impact Information

Background

Open DC Hub is the hub software for the Direct Connect file sharing network.

Description

Donato Ferrante discovered a buffer overflow vulnerability in the RedirectAll command of the Open DC Hub.

Impact

Upon exploitation, a remote user with administrative privileges can execute arbitrary code on the system running the Open DC Hub.

3.  Resolution Information

Workaround

Only give administrative rights to trusted users.

Resolution

All Open DC Hub users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-p2p/opendchub-0.7.14-r2"

4.  References



Print

Page updated November 28, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.