Gentoo Logo

Sun and Blackdown Java: Applet privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200411-38 / Java
Release Date November 29, 2004
Latest Revision May 31, 2006: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-java/sun-jdk < 1.4.2.06 >= 1.4.2.06 x86 amd64
dev-java/sun-jre-bin < 1.4.2.06 >= 1.4.2.06 x86 amd64
dev-java/blackdown-jdk < 1.4.2.01 >= 1.4.2.01 x86 amd64
dev-java/blackdown-jre < 1.4.2.01 >= 1.4.2.01 x86 amd64

Related bugreports: #72172, #72221

Synopsis

The Java plug-in security in Sun and Blackdown Java environments can be bypassed to access arbitrary packages, allowing untrusted Java applets to perform unrestricted actions on the host system.

2.  Impact Information

Background

Sun and Blackdown both provide implementations of Java Development Kits (JDK) and Java Runtime Environments (JRE). All these implementations provide a Java plug-in that can be used to execute Java applets in a restricted environment for web browsers.

Description

All Java plug-ins are subject to a vulnerability allowing unrestricted Java package access.

Impact

A remote attacker could embed a malicious Java applet in a web page and entice a victim to view it. This applet can then bypass security restrictions and execute any command or access any file with the rights of the user running the web browser.

3.  Resolution Information

Workaround

As a workaround you could disable Java applets on your web browser.

Resolution

All Sun JDK users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.4.2.06"

All Sun JRE users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.4.2.06"

All Blackdown JDK users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/blackdown-jdk-1.4.2.01"

All Blackdown JRE users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/blackdown-jre-1.4.2.01"

Note: You should unmerge all vulnerable versions to be fully protected.

4.  References



Print

Page updated November 29, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.