Gentoo Logo

Vim, gVim: Vulnerable options in modelines


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200412-10 / vim
Release Date December 15, 2004
Latest Revision December 15, 2004: 01
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-editors/vim < 6.3-r2 >= 6.3-r2 All supported architectures
app-editors/gvim < 6.3-r2 >= 6.3-r2 All supported architectures

Related bugreports: #73715


Several vulnerabilities related to the use of options in modelines have been found and fixed in Vim. They could potentially result in a local user escalating privileges.

2.  Impact Information


Vim is an efficient, highly configurable improved version of the classic 'vi' text editor. gVim is the GUI version of Vim.


Gentoo's Vim maintainer, Ciaran McCreesh, found several vulnerabilities related to the use of options in Vim modelines. Options like 'termcap', 'printdevice', 'titleold', 'filetype', 'syntax', 'backupext', 'keymap', 'patchmode' or 'langmenu' could be abused.


A local attacker could write a malicious file in a world readable location which, when opened in a modeline-enabled Vim, could trigger arbitrary commands with the rights of the user opening the file, resulting in privilege escalation. Please note that modelines are disabled by default in the /etc/vimrc file provided in Gentoo.

3.  Resolution Information


There is no known workaround at this time.


All Vim users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/vim-6.3-r2"

All gVim users should also upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/gvim-6.3-r2"

4.  References


Page updated December 15, 2004

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.