Gentoo Logo

mpg123: Buffer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200501-14 / media-sound/mpg123
Release Date January 10, 2005
Latest Revision January 10, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-sound/mpg123 < 0.59s-r9 >= 0.59s-r9 All supported architectures

Related bugreports: #76862

Synopsis

An attacker may be able to execute arbitrary code by way of specially crafted MP2 or MP3 files.

2.  Impact Information

Background

mpg123 is a real-time MPEG audio player.

Description

mpg123 improperly parses frame headers in input streams.

Impact

By inducing a user to play a malicious file, an attacker may be able to exploit a buffer overflow to execute arbitrary code with the permissions of the user running mpg123.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mpg123 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-sound/mpg123-0.59s-r9"

4.  References



Print

Page updated January 10, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.