Gentoo Logo

Konqueror: Java sandbox vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200501-16 / Konqueror, kde, kdelibs
Release Date January 11, 2005
Latest Revision January 12, 2005: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
kde-base/kdelibs < 3.3.2 >= 3.3.2 All supported architectures

Related bugreports: #72750

Synopsis

The Java sandbox environment in Konqueror can be bypassed to access arbitrary packages, allowing untrusted Java applets to perform unrestricted actions on the host system.

2.  Impact Information

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. Konqueror is the KDE web browser and file manager.

Description

Konqueror contains two errors that allow JavaScript scripts and Java applets to have access to restricted Java classes.

Impact

A remote attacker could embed a malicious Java applet in a web page and entice a victim to view it. This applet can then bypass security restrictions and execute any command, or access any file with the rights of the user running Konqueror.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All kdelibs users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose kde-base/kdelibs

4.  References



Print

Page updated January 11, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.