Gentoo Logo

mod_python: Publisher Handler vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200502-14 / mod_python
Release Date February 13, 2005
Latest Revision December 30, 2007: 03
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apache/mod_python < 3.1.3-r1 >= 3.1.3-r1, revision >= 2.7.11 All supported architectures

Related bugreports: #80109

Synopsis

mod_python contains a vulnerability in the Publisher Handler potentially leading to information disclosure.

2.  Impact Information

Background

mod_python is an Apache module that embeds the Python interpreter within the server allowing Python-based web-applications to be created.

Description

Graham Dumpleton discovered a vulnerability in mod_python's Publisher Handler.

Impact

By requesting a specially crafted URL for a published module page, an attacker could obtain information about restricted variables.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mod_python users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose www-apache/mod_python

4.  References



Print

Page updated February 13, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.