Gentoo Logo

OpenMotif, LessTif: New libXpm buffer overflows

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200503-08 / openmotif
Release Date March 04, 2005
Latest Revision March 04, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
x11-libs/openmotif < 2.2.3-r3 >= 2.2.3-r3, revision >= 2.1.30-r9 All supported architectures
x11-libs/lesstif < 0.94.0-r2 >= 0.94.0-r2 All supported architectures

Related bugreports: #83655, #83656

Synopsis

A new vulnerability has been discovered in libXpm, which is included in OpenMotif and LessTif, that can potentially lead to remote code execution.

2.  Impact Information

Background

LessTif is a clone of OSF/Motif, which is a standard user interface toolkit available on Unix and Linux. OpenMotif also provides a free version of the Motif toolkit for open source applications.

Description

Chris Gilbert discovered potentially exploitable buffer overflow cases in libXpm that weren't fixed in previous libXpm security advisories.

Impact

A carefully-crafted XPM file could crash applications making use of the OpenMotif or LessTif toolkits, potentially allowing the execution of arbitrary code with the privileges of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All OpenMotif users should upgrade to an unaffected version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose x11-libs/openmotif

All LessTif users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-libs/lesstif-0.94.0-r2"

4.  References



Print

Page updated March 04, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.