Gentoo Logo

rxvt-unicode: Buffer overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200503-23 / rxvt-unicode
Release Date March 20, 2005
Latest Revision March 20, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
x11-terms/rxvt-unicode < 5.3 >= 5.3, < 4.8 All supported architectures

Related bugreports: #84680

Synopsis

rxvt-unicode is vulnerable to a buffer overflow that could lead to the execution of arbitrary code.

2.  Impact Information

Background

rxvt-unicode is a clone of the well known terminal emulator rxvt.

Description

Rob Holland of the Gentoo Linux Security Audit Team discovered that rxvt-unicode fails to properly check input length.

Impact

Successful exploitation would allow an attacker to execute arbitrary code with the permissions of the user running rxvt-unicode.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All rxvt-unicode users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/rxvt-unicode-5.3"

4.  References



Print

Page updated March 20, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.