Gentoo Logo

Sylpheed, Sylpheed-claws: Message reply overflow

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200503-26 / sylpheed sylpheed-claws
Release Date March 20, 2005
Latest Revision March 20, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
mail-client/sylpheed < 1.0.3 >= 1.0.3 All supported architectures
mail-client/sylpheed-claws < 1.0.3 >= 1.0.3 All supported architectures

Related bugreports: #84056

Synopsis

Sylpheed and Sylpheed-claws contain a vulnerability that can be triggered when replying to specially crafted messages.

2.  Impact Information

Background

Sylpheed is a lightweight email client and newsreader. Sylpheed-claws is a 'bleeding edge' version of Sylpheed.

Description

Sylpheed and Sylpheed-claws fail to properly handle non-ASCII characters in email headers when composing reply messages.

Impact

An attacker can send an email containing a malicious non-ASCII header which, when replied to, would cause the program to crash, potentially allowing the execution of arbitrary code with the privileges of the user running the software.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Sylpheed users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/sylpheed-1.0.3"

All Sylpheed-claws users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/sylpheed-claws-1.0.3"

4.  References



Print

Page updated March 20, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.