Gentoo Logo

Gld: Remote execution of arbitrary code

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200504-10 / Gld
Release Date April 13, 2005
Latest Revision May 22, 2006: 02
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
mail-filter/gld <= 1.4 >= 1.5 All supported architectures

Related bugreports: #88904

Synopsis

Gld contains several serious vulnerabilities, potentially resulting in the execution of arbitrary code as the root user.

2.  Impact Information

Background

Gld is a standalone greylisting server for Postfix.

Description

dong-hun discovered several buffer overflows in server.c, as well as several format string vulnerabilities in cnf.c.

Impact

An attacker could exploit this vulnerability to execute arbitrary code with the permissions of the user running Gld, the default user being root.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Gld users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-filter/gld-1.5"

4.  References



Print

Page updated April 13, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.