Gentoo Logo

PHP: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200504-15 / PHP
Release Date April 18, 2005
Latest Revision April 18, 2005: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-php/php < 4.3.11 >= 4.3.11 All supported architectures
dev-php/mod_php < 4.3.11 >= 4.3.11 All supported architectures
dev-php/php-cgi < 4.3.11 >= 4.3.11 All supported architectures

Related bugreports: #87517

Synopsis

Several vulnerabilities were found and fixed in PHP image handling functions, potentially resulting in Denial of Service conditions or the remote execution of arbitrary code.

2.  Impact Information

Background

PHP is a general-purpose scripting language widely used to develop web-based applications. It can run inside a web server using the mod_php module or the CGI version of PHP, or can run stand-alone in a CLI.

Description

An integer overflow and an unbound recursion were discovered in the processing of Image File Directory tags in PHP's EXIF module (CAN-2005-1042, CAN-2005-1043). Furthermore, two infinite loops have been discovered in the getimagesize() function when processing IFF or JPEG images (CAN-2005-0524, CAN-2005-0525).

Impact

A remote attacker could craft an image file with a malicious EXIF IFD tag, a large IFD nesting level or invalid size parameters and send it to a web application that would process this user-provided image using one of the affected functions. This could result in denying service on the attacked server and potentially executing arbitrary code with the rights of the web server.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PHP users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-php/php-4.3.11"

All mod_php users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-php/mod_php-4.3.11"

All php-cgi users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-php/php-cgi-4.3.11"

4.  References



Print

Page updated April 18, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.