Gentoo Logo

Ethereal: Numerous vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200505-03 / Ethereal
Release Date May 06, 2005
Latest Revision May 06, 2005: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-analyzer/ethereal < 0.10.11 >= 0.10.11 All supported architectures

Related bugreports: #90539

Synopsis

Ethereal is vulnerable to numerous vulnerabilities potentially resulting in the execution of arbitrary code or abnormal termination.

2.  Impact Information

Background

Ethereal is a feature rich network protocol analyzer.

Description

There are numerous vulnerabilities in versions of Ethereal prior to 0.10.11, including:

  • The ANSI A and DHCP dissectors are vulnerable to format string vulnerabilities.
  • The DISTCC, FCELS, SIP, ISIS, CMIP, CMP, CMS, CRMF, ESS, OCSP, PKIX1Explitit, PKIX Qualified, X.509, Q.931, MEGACO, NCP, ISUP, TCAP and Presentation dissectors are vulnerable to buffer overflows.
  • The KINK, WSP, SMB Mailslot, H.245, MGCP, Q.931, RPC, GSM and SMB NETLOGON dissectors are vulnerable to pointer handling errors.
  • The LMP, KINK, MGCP, RSVP, SRVLOC, EIGRP, MEGACO, DLSw, NCP and L2TP dissectors are vulnerable to looping problems.
  • The Telnet and DHCP dissectors could abort.
  • The TZSP, Bittorrent, SMB, MGCP and ISUP dissectors could cause a segmentation fault.
  • The WSP, 802.3 Slow protocols, BER, SMB Mailslot, SMB, NDPS, IAX2, RADIUS, SMB PIPE, MRDISC and TCAP dissectors could throw assertions.
  • The DICOM, NDPS and ICEP dissectors are vulnerable to memory handling errors.
  • The GSM MAP, AIM, Fibre Channel,SRVLOC, NDPS, LDAP and NTLMSSP dissectors could terminate abnormallly.

Impact

An attacker might be able to use these vulnerabilities to crash Ethereal and execute arbitrary code with the permissions of the user running Ethereal, which could be the root user.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Ethereal users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-analyzer/ethereal-0.10.11"

4.  References



Print

Page updated May 06, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.