Gentoo Logo

GnuTLS: Denial of Service vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200505-04 / GnuTLS
Release Date May 09, 2005
Latest Revision May 09, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-libs/gnutls < 1.2.3 >= 1.2.3, revision >= 1.0.25 All supported architectures

Related bugreports: #90726


The GnuTLS library is vulnerable to Denial of Service attacks.

2.  Impact Information


GnuTLS is a free TLS 1.0 and SSL 3.0 implementation for the GNU project.


A vulnerability has been discovered in the record packet parsing in the GnuTLS library. Additionally, a flaw was also found in the RSA key export functionality.


A remote attacker could exploit this vulnerability and cause a Denial of Service to any application that utilizes the GnuTLS library.

3.  Resolution Information


There is no known workaround at this time.


All GnuTLS users should remove the existing installation and upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --unmerge gnutls
# emerge --ask --oneshot --verbose net-libs/gnutls

Due to small API changes with the previous version, please do the following to ensure your applications are using the latest GnuTLS that you just emerged.

Code Listing 3.2: Resolution

# revdep-rebuild --soname-regexp[0-1]

Previously exported RSA keys can be fixed by executing the following command on the key files:

Code Listing 3.3: Resolution

# certtool -k infile outfile

4.  References


Page updated May 09, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.