Gentoo Logo

Mozilla Suite, Mozilla Firefox: Remote compromise

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200505-11 / mozilla
Release Date May 15, 2005
Latest Revision May 15, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-client/mozilla-firefox < 1.0.4 >= 1.0.4 All supported architectures
www-client/mozilla-firefox-bin < 1.0.4 >= 1.0.4 All supported architectures
www-client/mozilla < 1.7.8 >= 1.7.8 All supported architectures
www-client/mozilla-bin < 1.7.8 >= 1.7.8 All supported architectures

Related bugreports: #91859, #92393, #92394

Synopsis

Several vulnerabilities in the Mozilla Suite and Firefox allow an attacker to conduct cross-site scripting attacks or to execute arbitrary code.

2.  Impact Information

Background

The Mozilla Suite is a popular all-in-one web browser that includes a mail and news reader. Mozilla Firefox is the next-generation browser from the Mozilla project.

Description

The Mozilla Suite and Firefox do not properly protect "IFRAME" JavaScript URLs from being executed in context of another URL in the history list (CAN-2005-1476). The Mozilla Suite and Firefox also fail to verify the "IconURL" parameter of the "InstallTrigger.install()" function (CAN-2005-1477). Michael Krax and Georgi Guninski discovered that it is possible to bypass JavaScript-injection security checks by wrapping the javascript: URL within the view-source: or jar: pseudo-protocols (MFSA2005-43).

Impact

A malicious remote attacker could use the "IFRAME" issue to execute arbitrary JavaScript code within the context of another website, allowing to steal cookies or other sensitive data. By supplying a javascript: URL as the "IconURL" parameter of the "InstallTrigger.Install()" function, a remote attacker could also execute arbitrary JavaScript code. Combining both vulnerabilities with a website which is allowed to install software or wrapping javascript: URLs within the view-source: or jar: pseudo-protocols could possibly lead to the execution of arbitrary code with user privileges.

3.  Resolution Information

Workaround

Affected systems can be protected by disabling JavaScript. However, we encourage Mozilla Suite or Mozilla Firefox users to upgrade to the latest available version.

Resolution

All Mozilla Firefox users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.0.4"

All Mozilla Firefox binary users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-1.0.4"

All Mozilla Suite users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-1.7.8"

All Mozilla Suite binary users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-client/mozilla-bin-1.7.8"

4.  References



Print

Page updated May 15, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.