Gentoo Logo

PostgreSQL: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200505-12 / postgresql
Release Date May 15, 2005
Latest Revision June 26, 2007: 04
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-db/postgresql < 7.3.10, < 7.4.7-r2, < 8.0.2-r1 = 7.3*, = 7.4*, revision >= 8.0.1-r3, >= 8.0.2-r1 All supported architectures

Related bugreports: #91231

Synopsis

PostgreSQL is vulnerable to Denial of Service attacks and possibly allows unprivileged users to gain administrator rights.

2.  Impact Information

Background

PostgreSQL is a SQL compliant, open source object-relational database management system.

Description

PostgreSQL gives public EXECUTE access to a number of character conversion routines, but doesn't validate the given arguments (CAN-2005-1409). It has also been reported that the contrib/tsearch2 module of PostgreSQL misdeclares the return value of some functions as "internal" (CAN-2005-1410).

Impact

An attacker could call the character conversion routines with specially setup arguments to crash the backend process of PostgreSQL or to potentially gain administrator rights. A malicious user could also call the misdeclared functions of the contrib/tsearch2 module, resulting in a Denial of Service or other, yet uninvestigated, impacts.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should update to the latest available version and follow the guide at http://www.postgresql.org/about/news.315

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql

4.  References



Print

Page updated May 15, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.