Gentoo Logo

Sun and Blackdown Java: Applet privilege escalation

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200506-14 / sun-jdk sun-jre-bin blackdown-jre blackdown-jdk
Release Date June 19, 2005
Latest Revision June 19, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-java/sun-jdk < 1.4.2.08 >= 1.4.2.08 All supported architectures
dev-java/sun-jre-bin < 1.4.2.08 >= 1.4.2.08 All supported architectures
dev-java/blackdown-jdk < 1.4.2.02 >= 1.4.2.02 All supported architectures
dev-java/blackdown-jre < 1.4.2.02 >= 1.4.2.02 All supported architectures

Related bugreports: #96092, #96229

Synopsis

Sun's and Blackdown's JDK or JRE may allow untrusted applets to elevate their privileges.

2.  Impact Information

Background

Sun and Blackdown both provide implementations of the Java Development Kit (JDK) and Java Runtime Environment (JRE).

Description

Both Sun's and Blackdown's JDK and JRE may allow untrusted applets to elevate privileges.

Impact

A remote attacker could embed a malicious Java applet in a web page and entice a victim to view it. This applet can then bypass security restrictions and execute any command or access any file with the rights of the user running the web browser.

3.  Resolution Information

Workaround

There are no known workarounds at this time.

Resolution

All Sun JDK users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.4.2.08"

All Sun JRE users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.4.2.08"

All Blackdown JDK users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/blackdown-jdk-1.4.2.02"

All Blackdown JRE users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/blackdown-jre-1.4.2.02"

Note to SPARC users: There is no stable secure Blackdown Java for the SPARC architecture. Affected users should remove the package until a SPARC package is released.

4.  References



Print

Page updated June 19, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.