Gentoo Logo

SquirrelMail: Several XSS vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200506-19 / SquirrelMail
Release Date June 21, 2005
Latest Revision June 21, 2005: 01
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
mail-client/squirrelmail < 1.4.4 >= 1.4.4, < 1.4.0 All supported architectures

Related bugreports: #95937

Synopsis

Squirrelmail is vulnerable to several cross-site scripting vulnerabilities which could lead to a compromise of webmail accounts.

2.  Impact Information

Background

SquirrelMail is a webmail package written in PHP. It supports IMAP and SMTP protocols.

Description

SquirrelMail is vulnerable to several cross-site scripting issues, most reported by Martijn Brinkers.

Impact

By enticing a user to read a specially-crafted e-mail or using a manipulated URL, an attacker can execute arbitrary scripts running in the context of the victim's browser. This could lead to a compromise of the user's webmail account, cookie theft, etc.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All SquirrelMail users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.4"

Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.

4.  References



Print

Page updated June 21, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.