Gentoo Logo

phpGroupWare, eGroupWare: PHP script injection vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200507-08 / phpgroupware egroupware
Release Date July 10, 2005
Latest Revision July 10, 2005: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/phpgroupware < 0.9.16.006 >= 0.9.16.006 All supported architectures
www-apps/egroupware < 1.0.0.008 >= 1.0.0.008 All supported architectures

Related bugreports: #97460, #97651

Synopsis

phpGroupWare and eGroupWare include an XML-RPC implementation which allows remote attackers to execute arbitrary PHP script commands.

2.  Impact Information

Background

phpGroupWare and eGroupWare are web based collaboration software suites.

Description

The XML-RPC implementations of phpGroupWare and eGroupWare fail to sanitize input sent to the XML-RPC server using the "POST" method.

Impact

A remote attacker could exploit the XML-RPC vulnerability to execute arbitrary PHP script code by sending specially crafted XML data to the XML-RPC servers of phpGroupWare or eGroupWare.

3.  Resolution Information

Workaround

There are no known workarounds at this time.

Resolution

All phpGroupWare users should upgrade to the latest available version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-app/phpgroupware-0.9.16.006"

All eGroupWare users should upgrade to the latest available version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-app/egroupware-1.0.0.008"

4.  References



Print

Page updated July 10, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.