Gentoo Logo

Adobe Acrobat Reader: Buffer overflow vulnerability


1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200507-09 / acroread
Release Date July 11, 2005
Latest Revision July 11, 2005: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/acroread <= 5.10 >= 7.0 All supported architectures

Related bugreports: #98101


Adobe Acrobat Reader is vulnerable to a buffer overflow that could lead to remote execution of arbitrary code.

2.  Impact Information


Adobe Acrobat Reader is a utility used to view PDF files.


A buffer overflow has been discovered in the UnixAppOpenFilePerform() function, which is called when Adobe Acrobat Reader tries to open a file with the "\Filespec" tag.


By enticing a user to open a specially crafted PDF document, a remote attacker could exploit this vulnerability to execute arbitrary code.

3.  Resolution Information


There is no known workaround at this time.


Since Adobe will most likely not update the 5.0 series of Adobe Acrobat Reader for Linux, all users should upgrade to the latest available version of the 7.0 series:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/acroread-7.0"

4.  References


Page updated July 11, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2015 Gentoo Foundation, Inc. Questions, Comments? Contact us.