Gentoo Logo

MediaWiki: Cross-site scripting vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200507-18 / mediawiki
Release Date July 20, 2005
Latest Revision August 11, 2005: 03
Impact low
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/mediawiki < 1.4.6 >= 1.4.6 All supported architectures

Related bugreports: #99132

Synopsis

MediaWiki is vulnerable to a cross-site scripting attack that could allow arbitrary JavaScript code execution.

2.  Impact Information

Background

MediaWiki is a collaborative editing software, used by big projects like Wikipedia.

Description

MediaWiki fails to escape a parameter in the page move template correctly.

Impact

By enticing a user to visit a specially crafted URL, a remote attacker could exploit this vulnerability to inject malicious JavaScript code that will be executed in a user's browser session in the context of the vulnerable site.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All MediaWiki users should upgrade to the latest available version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/mediawiki-1.4.7"

4.  References



Print

Page updated July 20, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.