Gentoo Logo

phpWebSite: Arbitrary command execution through XML-RPC and SQL injection

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200508-21 / phpwebsite
Release Date August 31, 2005
Latest Revision August 31, 2005: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/phpwebsite < 0.10.2_rc2 >= 0.10.2_rc2 All supported architectures

Related bugreports: #102785

Synopsis

phpWebSite is vulnerable to multiple issues which result in the execution of arbitrary code and SQL injection.

2.  Impact Information

Background

phpWebSite is a web site content management system.

Description

phpWebSite uses an XML-RPC library that improperly handles XML-RPC requests and responses with malformed nested tags. Furthermore, "matrix_killer" reported that phpWebSite is vulnerable to an SQL injection attack.

Impact

A malicious remote user could exploit this vulnerability to inject arbitrary PHP script code into eval() statements by sending a specially crafted XML document, and also inject SQL commands to access the underlying database directly.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All phpWebSite users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/phpwebsite-0.10.2_rc2"

4.  References



Print

Page updated August 31, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.