Gentoo Logo

Uim: Privilege escalation vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200510-03 / uim
Release Date October 04, 2005
Latest Revision May 22, 2006: 02
Impact normal
Exploitable local
Package Vulnerable versions Unaffected versions Architecture(s)
app-i18n/uim < 0.4.9.1 >= 0.4.9.1 All supported architectures

Related bugreports: #107748

Synopsis

Under certain conditions, applications linked against Uim suffer from a privilege escalation vulnerability.

2.  Impact Information

Background

Uim is a multilingual input method library which provides secure and useful input method for all languages.

Description

Masanari Yamamoto discovered that Uim uses environment variables incorrectly. This bug causes a privilege escalation if setuid/setgid applications are linked to libuim. This bug only affects immodule-enabled Qt (if you build Qt 3.3.2 or later versions with USE="immqt" or USE="immqt-bc").

Impact

A malicious local user could exploit this vulnerability to execute arbitrary code with escalated privileges.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Uim users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.9.1"

4.  References



Print

Page updated October 04, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.