Gentoo Logo

RealPlayer, Helix Player: Format string vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200510-07 / realplayer helixplayer
Release Date October 07, 2005
Latest Revision November 22, 2005: 02
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
media-video/realplayer < 10.0.6 >= 10.0.6 All supported architectures
media-video/helixplayer < 1.0.6 All supported architectures

Related bugreports: #107309

Synopsis

RealPlayer and Helix Player are vulnerable to a format string vulnerability resulting in the execution of arbitrary code.

2.  Impact Information

Background

RealPlayer is a multimedia player capable of handling multiple multimedia file formats. Helix Player is an open source media player for Linux.

Description

"c0ntex" reported that RealPlayer and Helix Player suffer from a heap overflow.

Impact

By enticing a user to play a specially crafted realpix (.rp) or realtext (.rt) file, an attacker could execute arbitrary code with the permissions of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All RealPlayer users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/realplayer-10.0.6"

Note to Helix Player users: There is currently no stable secure Helix Player package. Affected users should remove the package until an updated Helix Player package is released.

4.  References



Print

Page updated October 07, 2005

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.