Gentoo Logo

HylaFAX: Multiple vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200601-03 / hylafax
Release Date January 06, 2006
Latest Revision January 06, 2006: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
net-misc/hylafax < 4.2.3-r1 >= 4.2.3-r1 All supported architectures

Related bugreports: #116389

Synopsis

HylaFAX is vulnerable to arbitrary code execution and unauthorized access vulnerabilities.

2.  Impact Information

Background

HylaFAX is an enterprise-class system for sending and receiving facsimile messages and for sending alpha-numeric pages.

Description

Patrice Fournier discovered that HylaFAX runs the notify script on untrusted user input. Furthermore, users can log in without a password when HylaFAX is installed with the pam USE-flag disabled.

Impact

An attacker could exploit the input validation vulnerability to run arbitrary code as the user running HylaFAX, which is usually uucp. The password vulnerability could be exploited to log in without proper user credentials.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All HylaFAX users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/hylafax-4.2.3-r1"

4.  References



Print

Page updated January 06, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.