Gentoo Logo

mod_auth_pgsql: Multiple format string vulnerabilities

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200601-05 / mod_auth_pgsql
Release Date January 10, 2006
Latest Revision December 30, 2007: 03
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apache/mod_auth_pgsql < 2.0.3 >= 2.0.3, < 1.0.0 All supported architectures

Related bugreports: #118096

Synopsis

Format string vulnerabilities in mod_auth_pgsql may lead to the execution of arbitrary code.

2.  Impact Information

Background

mod_auth_pgsql is an Apache2 module that allows user authentication against a PostgreSQL database.

Description

The error logging functions of mod_auth_pgsql fail to validate certain strings before passing them to syslog, resulting in format string vulnerabilities.

Impact

An unauthenticated remote attacker could exploit these vulnerabilities to execute arbitrary code with the rights of the user running the Apache2 server by sending specially crafted login names.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All mod_auth_pgsql users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apache/mod_auth_pgsql-2.0.3"

4.  References



Print

Page updated January 10, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.