Gentoo Logo

Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200601-17 / xpdf poppler gpdf libextractor pdftohtml
Release Date January 30, 2006
Latest Revision January 30, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
app-text/xpdf < 3.01-r5 >= 3.01-r5 All supported architectures
app-text/poppler < 0.4.3-r4 >= 0.4.3-r4 All supported architectures
app-text/gpdf < 2.10.0-r3 >= 2.10.0-r3 All supported architectures
media-libs/libextractor < 0.5.9 >= 0.5.9 All supported architectures
app-text/pdftohtml < 0.36-r4 All supported architectures

Related bugreports: #117481, #117494, #117495, #115789, #118665

Synopsis

Xpdf, Poppler, GPdf, libextractor and pdftohtml are vulnerable to integer overflows that may be exploited to execute arbitrary code.

2.  Impact Information

Background

Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base. GPdf is a PDF file viewer for the GNOME 2 platform, also based on Xpdf. libextractor is a library which includes Xpdf code to extract arbitrary meta-data from files. pdftohtml is a utility to convert PDF files to HTML or XML formats that makes use of Xpdf code to decode PDF files.

Description

Chris Evans has reported some integer overflows in Xpdf when attempting to calculate buffer sizes for memory allocation, leading to a heap overflow and a potential infinite loop when handling malformed input files.

Impact

By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r5"

All Poppler users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/poppler-0.4.3-r4"

All GPdf users should upgrade to the latest version:

Code Listing 3.3: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r3"

All libextractor users should upgrade to the latest version:

Code Listing 3.4: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libextractor-0.5.9"

All pdftohtml users should migrate to the latest stable version of Poppler.

4.  References



Print

Page updated January 30, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.