Gentoo Logo

libtasn1, GNU TLS: Security flaw in DER decoding

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200602-08 / libtasn1
Release Date February 16, 2006
Latest Revision February 16, 2006: 01
Impact high
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
dev-libs/libtasn1 < 0.2.18 >= 0.2.18 All supported architectures
net-libs/gnutls < 1.2.10 >= 1.2.10 All supported architectures

Related bugreports: #122307

Synopsis

A flaw in the parsing of Distinguished Encoding Rules (DER) has been discovered in libtasn1, potentially resulting in the execution of arbitrary code.

2.  Impact Information

Background

Libtasn1 is a library used to parse ASN.1 (Abstract Syntax Notation One) objects, and perform DER (Distinguished Encoding Rules) decoding. Libtasn1 is included with the GNU TLS library, which is used by applications to provide a cryptographically secure communications channel.

Description

Evgeny Legerov has reported a flaw in the DER decoding routines provided by libtasn1, which could cause an out of bounds access to occur.

Impact

A remote attacker could cause an application using libtasn1 to crash and potentially execute arbitrary code by sending specially crafted input.

3.  Resolution Information

Workaround

There is no known workaround at this time.

Resolution

All libtasn1 users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libtasn1-0.2.18"

All GNU TLS users should upgrade to the latest version:

Code Listing 3.2: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/gnutls-1.2.10"

4.  References



Print

Page updated February 16, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.