Gentoo Logo

WordPress: SQL injection vulnerability

Content:

1.  Gentoo Linux Security Advisory

Version Information

Advisory Reference GLSA 200603-01 / WordPress
Release Date March 04, 2006
Latest Revision March 04, 2006: 01
Impact normal
Exploitable remote
Package Vulnerable versions Unaffected versions Architecture(s)
www-apps/wordpress <= 1.5.2 >= 2.0.1 All supported architectures

Related bugreports: #121661

Synopsis

WordPress is vulnerable to an SQL injection vulnerability.

2.  Impact Information

Background

WordPress is a PHP and MySQL based content management and publishing system.

Description

Patrik Karlsson reported that WordPress 1.5.2 makes use of an insufficiently filtered User Agent string in SQL queries related to comments posting. This vulnerability was already fixed in the 2.0-series of WordPress.

Impact

An attacker could send a comment with a malicious User Agent parameter, resulting in SQL injection and potentially in the subversion of the WordPress database. This vulnerability wouldn't affect WordPress sites which do not allow comments or which require that comments go through a moderator.

3.  Resolution Information

Workaround

Disable or moderate comments on your WordPress blogs.

Resolution

All WordPress users should upgrade to the latest version:

Code Listing 3.1: Resolution

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.1"

4.  References



Print

Page updated March 04, 2006

Summary: This is a Gentoo Linux Security Advisory

Security Team
Contact Address

Donate to support our development efforts.

Copyright 2001-2014 Gentoo Foundation, Inc. Questions, Comments? Contact us.